ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6222. Авторская задача

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

В начальный момент на поле находятся две Черепахи. Первая Черепаха находится в начале координат и направлена вверх (вдоль положительного направления оси ординат). Вторая Черепаха находится в неизвестной точке поля и направлена вправо (вдоль положительного направления оси абсцисс).

Каждая Черепаха выполнила следующую программу:

Повтори 2 [Вперёд 25 Направо 90 Вперёд 22 Направо 90]

Определите максимально возможное количество точек с целочисленными координатами, которые могут оказаться внутри пересечения фигур, нарисованных двумя Черепахами. Точки, находящиеся на линиях, учитывать не следует.

from turtle import *

tracer(0)
pensize(6)
screensize(2500, 6000)

scale = 20
dot_size = 5
dot_color = "#696969"

lt(90)

color("#A7D380")


for i in range(2):
    fd(25 * scale)
    rt(90)
    fd(22 * scale)
    rt(90)


pu()
fd(24.5 * scale)
rt(90)
pd()

color("#F76D47")


for i in range(2):
    fd(25 * scale)
    rt(90)
    fd(22 * scale)
    rt(90)
update()

pu()
for x in range(0, 23):
    for y in range(0, 26):
        goto(x * scale, y * scale)
        dot(dot_size, dot_color)
print(22 * 21)
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие