ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6221. Авторская задача

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм:

Повтори 4 [Направо 120 Вперед 12]
Опустить хвост
Повтори 7 [Вперёд 16 Направо 90]
Повтори 4 [Направо 60 Вперёд 40 Направо 40]

Определите, сколько точек с целочисленными координатами будут находиться внутри области пересечения фигур, ограниченных заданными алгоритмом линиями. Точки на линии учитывать не следует.

import math as m
from turtle import *

# Базовая настройка
tracer(0)
lt(90)
angles = []
coords = []
count = 0

pu()
for _ in range(4):
    rt(120)
    fd(12)
pd()

# Первая фигура
for i in range(7):
    if i < 4:
        angles.append(heading())
        coords.append((xcor(), ycor()))
    fd(16)
    rt(90)

k_1 = round(m.tan(m.radians(angles[0])), 8)
k_2 = round(m.tan(m.radians(angles[1])), 8)

b_2 = coords[1][1] - k_2 * coords[1][0]
b_3 = coords[2][1] - k_1 * coords[2][0]

# Прямая, до которой будем считать
range_y = ycor()

# Вторая фигура
for i in range(4):
    rt(60)
    fd(40)
    rt(30)


def get_min_max_coordinates(coordinates):
    min_x = m.floor(min(x for x, _ in coordinates))
    max_x = m.ceil(max(x for x, _ in coordinates))
    min_y = m.floor(min(y for _, y in coordinates))
    max_y = m.ceil(max(y for _, y in coordinates))
    return min_x, max_x, min_y, max_y


ranges = get_min_max_coordinates(coords)

for x in range(ranges[0], ranges[1]):
    for y in range(ranges[2], ranges[3]):
        if k_1 * x + b_3 < y < range_y and 
                k_2 * x + b_2 < y < range_y:
            count += 1
print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие