ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6220. Авторская задача

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм:

Повтори 8 [Вперёд 15 Направо 90 Вперёд 12 Направо 90]
Поднять хвост
Вперёд 2 Направо 90 Вперёд 3 Налево 90
Опустить хвост
Повтори 8 [Вперёд 22 Направо 90 Вперёд 17 Направо 90]

Определите площадь области объединения фигур, ограниченных заданными алгоритмом линиями. В ответе укажите только число. Единицу измерения указывать не нужно.

from turtle import *

# Базовая настройка
tracer(0)  # Отключаем анимацию
pensize(6)  # Размер пера
screensize(2500, 2500)  # Размер окна

scale = 30  # Масштаб
dot_size = 14  # Размер точек
dot_color = "white"  # Цвет точек

lt(90)  # Поворот по положительному направлению оси ординат

color("#A7D380")  # Цвет границ первой фигуры

# Первая фигура
for _ in range(8):
    fd(15 * scale)
    rt(90)
    fd(12 * scale)
    rt(90)

# Перемещение
pu()
fd(2 * scale)
rt(90)
fd(3 * scale)
lt(90)
pd()

color("#F76D47")  # Цвет границ второй фигуры

# Вторая фигура
for _ in range(8):
    fd(22 * scale)
    rt(90)
    fd(17 * scale)
    rt(90)

# Точки
pu()
for x in range(-50, 50):
    for y in range(-50, 50):
        goto(x * scale, y * scale)
        dot(dot_size, dot_color)
print(15 * 12 + 22 * 17 - 9 * 13)
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие