ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6219. Авторская задача

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм:

Налево 72
Повтори 4 [Вперёд 42 Направо 72 Вперёд 100 Направо 108]
Поднять хвост
Направо 72 Вперёд 30 Налево 90
Опустить хвост
Повтори 4 [Вперёд 72 Направо 90 Вперёд 30 Направо 90]

Определите, сколько точек с целочисленными координатами будут находиться внутри пересечения фигур, ограниченных заданными алгоритмом линиями. Точки на линии учитывать не следует.

from turtle import *

tracer(0)
pensize(6)
screensize(5500, 5500)

scale = 20
dot_size = 4
dot_color = "#696969"

lt(90)
lt(72)
color("#A7D380")

# Первая фигура
for i in range(4):
    fd(42 * scale)
    rt(72)
    fd(100 * scale)
    rt(108)

# Перемещение
pu()
rt(72)
fd(30 * scale)
lt(90)
pd()

color("#F76D47")

# Вторая фигура
for i in range(4):
    fd(72 * scale)
    rt(90)
    fd(30 * scale)
    rt(90)

# Точки
pu()
for x in range(-72, 1):
    for y in range(0, 114):
        goto(x * scale, y * scale)
        dot(dot_size, dot_color)

print(39 * 29)
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие