ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6223. Авторская задача

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм:

Повтори 9 [Вперёд 17 Налево 90 Вперед 8 Налево 90 Вперёд 17]
Поднять хвост
Налево 90 Вперед 3 Направо 90 Вперёд 5 Налево 90
Опустить хвост
Повтори 4 [Вперёд 97 Направо 90 Вперёд 132 Направо 90]

Определите периметр области пересечения фигур, ограниченных заданными алгоритмом линиями.

from turtle import *


tracer(0)
pensize(6)
screensize(2000, 2000)

scale = 30
dot_size = 14
dot_color = "white"

lt(90)

color("#A7D380")

for _ in range(9):
    fd(17 * scale)
    lt(90)
    fd(8 * scale)
    lt(90)
    fd(17 * scale)

pu()
lt(90)
fd(3 * scale)
rt(90)
fd(5 * scale)
lt(90)
pd()

color("#F76D47")

for _ in range(4):
    fd(97 * scale)
    rt(90)
    fd(132 * scale)
    rt(90)

pu()
for x in range(-5, 1):
    for y in range(-17, -4):
        goto(x * scale, y * scale)
        dot(dot_size, dot_color)

print(5 * 2 + 12 * 2)
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие