ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14041. ЕГКР 2025

Значение арифметического выражения 4210 + 4110 – x, где x – целое положительное число, не превышающее 3000, записали в четверичной системе счисления.

Определите наименьшее значение x, при котором в четверичной записи числа, являющегося значением данного арифметического выражения, содержится наибольшее количество нулей.

В ответе запишите число в десятичной системе счисления.

ans = []
for x in range(1, 3001):
    num = 4**210 + 4**110 - x
    cnt = 0
    while num:
        if num % 4 == 0: cnt += 1
        num //= 4
    ans.append([cnt, x])

print(min(ans, key=lambda x: (-x[0], x[1])))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие