ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14042. ФИПИ 2025

Значение арифметического выражения 7350 + 7150 – x, где x – целое положительное число, не превышающее 2300, записали в семеричной системе счисления.

Определите наибольшее значение x, при котором в семеричной записи числа, являющегося значением данного арифметического выражения, содержится ровно 200 нулей.

В ответе запишите число в десятичной системе счисления.

ans = []
for x in range(1, 2301):
    num = 7**350 + 7**150 - x
    cnt = 0
    while num:
        if num % 7 == 0: cnt += 1
        num //= 7
    if cnt == 200:
        ans.append(x)

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие