ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14043. Основная волна 2025

Значение арифметического выражения 9150 + 930 – x, где x – целое положительное число, не превышающее 3000, записали в девятеричной системе счисления.

Определите наименьшее значение x, при котором в девятеричной записи числа, являющегося значением данного арифметического выражения, содержится ровно 122 нуля.

В ответе запишите число в десятичной системе счисления.

ans = []
for x in range(1, 3001):
    num = 9**150 + 9**30 - x
    cnt = 0
    while num:
        if num % 9 == 0: cnt += 1
        num //= 9
    if cnt == 122:
        ans.append(x)

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие