ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14040. Досрочная волна 2025

Операнды арифметического выражения записаны в системе счисления с основанием 21:

82934x221 + 2924xx721 + 67564x821

В записи чисел переменной x обозначена неизвестная цифра из алфавита 21-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 20.

Для найденного значения x вычислите частное от деления значения арифметического выражения на 20 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:21]:
    num_1 = int(f'82934{x}2', 21)
    num_2 = int(f'2924{x}{x}7', 21)
    num_3 = int(f'67564{x}8', 21)
    num = num_1 + num_2 + num_3
    if num % 20 == 0:
        ans.append([x, num // 20])

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие