ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14039. Апробация 2025

Значение арифметического выражения 3100 – x, где x – целое положительное число, не превышающее 2030, записали в троичной системе счисления.

Определите наибольшее значение x, при котором в троичной записи числа, являющегося значением данного арифметического выражения, содержится ровно один нуль.

В ответе запишите число в десятичной системе счисления.

ans = []
for x in range(1, 2031):
    num = 3**100 - x
    cnt = 0
    while num:
        if num % 3 == 0: cnt += 1
        num //= 3
    if cnt == 1:
        ans.append(x)

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие