ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14012. Вариант ИМЦ СПб 2023

Операнды арифметического выражения записаны в системе счисления с основанием 13.

753x213 + 2x17313

В записи чисел переменной x обозначена неизвестная цифра из алфавита 13-ричной системы счисления. Определите наименьшее значение x, при котором значение данного арифметического выражения кратно 12. Для найденного значения x вычислите частное от деления значения арифметического выражения на 12 и укажите его в ответе в десятичной системе счисления. Основание системы счисления в ответе указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:13]:
    num_1 = int(f'753{x}2', 13)
    num_2 = int(f'2{x}173', 13)
    num = num_1 + num_2
    if num % 12 == 0:
        ans.append([x, num // 12])

print(min(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие