ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14011. ФИПИ 2023

Значение арифметического выражения

3 ∙ 102475 + 2 ∙ 25676 – 1677 – 2023

записали в системе счисления с основанием 32. Определите количество нулей в записи этого числа.

num = 3*1024**75 + 2*256**76 - 16**77 - 2023

cnt = 0
while num:
    if num % 32 == 0: cnt += 1
    num //= 32

print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие