ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14010. Апробация

Значение арифметического выражения   3100 — x, где x – целое положительное число, не превышающее 2030, записали в троичной системе счисления.

Определите наибольшее значение x, при котором в троичной записи числа, являющегося значением данного арифметического выражения, содержится ровно один нуль.

В ответе запишите число в десятичной системе счисления.

def count_zero(num, sys):
    count = 0
    while num:
        if num % sys == 0:
            count += 1
        num //= sys
    return count

for x in range(1, 2030)[::-1]:
    num = 3 ** 100 - x
    if count_zero(num, 3) == 1:
        print(x)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие