ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14013. ЕГКР

Значение арифметического выражения 4210 + 4110 – x, где x – целое положительное число, не превышающее 3000, записали в четверичной системе счисления.

Определите наименьшее значение x, при котором в четверичной записи числа, являющегося значением данного арифметического выражения, содержится наибольшее количество нулей.

В ответе запишите число в десятичной системе счисления.

def count_zero(num):
    count = 0
    while num:
        if num % 4 == 0:
            count += 1
        num //= 4
    return count


max_zeros = 0

for x in range(1, 3001):
    num = 4**210 + 4**110 - x
    max_zeros = max(max_zeros, count_zero(num))


for x in range(1, 3001):
    num = 4**210 + 4**110 - x
    if count_zero(num) == max_zeros:
        print(x)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие