ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9107. Типовая задача

Откройте файл электронной таблицы, содержащей в каждой строке восемь натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– в строке есть два числа, каждое из которых повторяется трижды, остальные два числа различны;
 – максимальное число строки не является повторяющимся числом.

В ответе запишите только число.

with open('922.txt') as f:
    data = [list(map(int, i.split())) for i in f]


def f1(arr):
    cnt = [arr.count(num) for num in set(arr)]
    return sorted(cnt) == [1, 1, 3, 3]


def f2(arr):
    mx = max(arr)
    return arr.count(mx) == 1



count = 0
for line in data:
    if f1(line) and f2(line):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие