ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

Алгоритм решения задания 9. Часть 4

В прошлой статье мы познакомились с программными методами решения заданий 9 ЕГЭ по информатике. Научились грамотно экспортировать данные из электронных таблиц, читать файлы с помощью Python и разобрали типовые функции, которыми будем пользоваться в наших решениях.

Теперь настало время закрепить пройденный материал и применить его на практике для решения первого типа заданий 9. Напомним, что в заданиях этого типа от нас требуется подсчитать количество строк, для которых одно или несколько условий выполняются одновременно.

Давайте далее разберём основные конструкции, которыми мы будем пользоваться для получения ответа и опробуем их на паре примеров.

Алгоритм решения

Итак, со считыванием данных мы уже познакомились еще в прошлой статье. Всегда будет использоваться только такая конструкция:

with open('file.txt') as f:
    data = [list(map(int, i.split())) for i in f]

После этого блока кода мы будем писать функции для проверки каждого условия из формулировки. Типовые функции мы уже рассмотрели, но под каждое задание мы будем их немного корректировать.

Теперь рассмотрим самое главное: последний блок, в котором будем проверять все строки на соответствие условиям и выводить ответ.

Как уже говорили, в заданиях первого типа нам нужно дать в ответ количество строк. Логично предположить, что следует создать некую переменную-счётчик, в которой будем хранить количество подходящих строк. Обычно такую переменную называют counter (счётчик) или сокращённо cnt. Изначально приравняем её к нулю:

# Счетчик 
counter = 0

Далее мы в цикле for переберём каждый список с числами из нашей переменной data:

for line in data:

Внутри цикла должно быть условие, при выполнении которого мы будем увеличивать значение счётчика в counter.

Если в задании сказано только об одном условии, то проверить его выполнение можно такой строчкой:

if f(line):

Здесь f – название функции, в которой мы и реализуем проверку условия.

Если же условий несколько, и они должны выполняться оба, то поставим между ними оператор and:

if f1(line) and f2(line):

Как вы уже могли понять, f1 и f2 — это названия функций для каждого из условий.

При выполнении этой строки кода с условным оператором if мы увеличим значение переменной counter на 1 такой записью:

counter += 1

После завершения цикла выведем значение этой переменной – это и будет ответом. Весь блок кода с проверкой строк и выводом ответа выглядит так:

# Счетчик
counter = 0

# Вычисление кол-ва строк
for line in data:
    if f1(line) and f2(line):
        counter += 1

# Вывод ответа
print(counter)

На этом всё. У нас есть начало программы со считыванием данных из файла и окончание с проверкой всех строк и выводом ответа. Эти два блока будут переходить из решения в решение и не будут меняться. Всё, что от нас требуется, — правильно составить функции для проверки условий. Давайте этим и займёмся на следующих примерах.

Пример 1

Для разогрева рассмотрим простую формулировку всего с одним условием:

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, в которых сумма наибольшего и наименьшего чисел не больше суммы двух оставшихся.

Открыть задание

Файл мы уже открыли, скопировали все значения в текстовый и сохранили под именем «9003.txt». Если вы не помните, как это делается, то вернитесь к прошлой статье.

В наших решениях далее будем опускать первый и последний блоки кода, которые мы уже разобрали выше. Сразу будем писать функции для проверки условий.

Поскольку в этом задании всего одно условие, то и функция у нас будет одна. Давайте построчно её составим. Для начала нужно определить наибольшее и наименьшее число в строке. В этом нам помогут функции max() и min() соответственно:

# Наибольшее
max_num = max(line)
# Наименьшее
min_num = min(line)

В следующей строке найдём сумму оставшихся чисел. Можем просто вычислить сумму всех чисел в строке и отнять от результата максимальное и минимальное числа.

# Cумма оставшихся
sum_rest = sum(line) - max_num - min_num

Теперь проверим, что сумма максимального и минимального меньше или равна сумме оставшихся чисел. Если это так, то вернём True, иначе – False. Запишем неравенство после оператора return:

# Не больше суммы двух оставшихся
return max_num + min_num <= sum_rest

И вся наша функция выглядит следующим образом:

# Условие
def f(line):
    # Наибольшее
    max_num = max(line)
    # Наименьшее
    min_num = min(line)
    # Cумма оставшихся
    sum_rest = sum(line) - max_num - min_num
    # Не больше суммы двух оставшихся
    return max_num + min_num <= sum_rest

На этом всё. Перед функцией вставляем блок с чтением данных, после – с проверкой каждой строки и выводом ответа. Всё наше решение выглядит так:

# Чтение данных из файла
with open('9003.txt') as f:
    data = [list(map(int, i.split())) for i in f]

# Условие
def f(line):
    # Наибольшее
    max_num = max(line)
    # Наименьшее
    min_num = min(line)
    # Cумма оставшихся
    sum_rest = sum(line) - max_num - min_num
    # Не больше суммы двух оставшихся
    return max_num + min_num <= sum_rest

# Счетчик
counter = 0

# Вычисление кол-ва строк
for line in data:
    if f(line):
        counter += 1

# Вывод ответа
print(counter)

Запускаем программу и на экране видим ответ на это задание – 15115.

Пример 2

Но вернёмся к заданиям с двумя условиями. Следующая у нас будет такая формулировка:

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполняются оба условия:

– в строке есть два числа, каждое из которых повторяется трижды, одно число без повторений;
 – наибольшее из повторяющихся чисел больше неповторяющегося числа.

В ответе запишите только число

Открыть задание

Перед тем как приступим к решению задания, давайте подумаем, как определить, что в строке два числа повторяются трижды. Предположим, что у нас есть такой список чисел: 0, 0, 0, 2, 2, 2, 4.

Воспользуемся разобранным в прошлой статье кодом для подсчёта количества вхождений каждого числа в список и выведем его на экран:

line = [0, 0, 0, 2, 2, 2, 4]

cnt = [line.count(i) for i in line]

print(cnt)
>>>[3, 3, 3, 3, 3, 3, 1]

Что же, у нас 6 троек и 1 единица. Первые три тройки означают вхождения в исходный список числа 0, а вторые – числа 2. Таким образом, в подходящей под рассматриваемое условие строке должно быть 6 троек и 1 единица.

Проверим наше утверждение и вычислим количество троек и единиц в списке cnt:

line = [0, 0, 0, 2, 2, 2, 4]

cnt = [line.count(i) for i in line]

if cnt.count(3) == 6 and cnt.count(1) == 1:
    print('Истина')

Отлично! Осталось оформить это в виде функции:

def f1(line):
    # Подсчитываем сколько раз повторяется каждое
    cnt = [line.count(i) for i in line]
    # 2 числа трижды: 2 * 3 = 6
    return cnt.count(3) == 6 and cnt.count(1) == 1

Теперь перейдём ко второму условию. Для него нам нужно будет составить список с повторяющимися и список с неповторяющимися числами, как мы это делали в прошлой статье:

# Все повторяющиеся
repeat = {i for i in line if line.count(i) > 1}
# Все неповторяющиеся
no_repeat = [i for i in line if line.count(i) == 1]

Из повторяющихся нам нужно наибольшее, так что воспользуемся уже знакомой функцией max(): max(repeat).

А поскольку не повторяется у нас всего одно число, то возьмем просто первый (и единственный) элемент из списка no_repeat. Вся функция для проверки второго условия выглядит так:

def f2(line):
    # Все повторяющиеся
    repeat = {i for i in line if line.count(i) > 1}
    # Все неповторяющиеся
    no_repeat = [i for i in line if line.count(i) == 1]
    return max(repeat) > no_repeat[0]

Теперь собираем все части нашего кода вместе и получаем такую программу:

# Чтение данных из файла
with open('9005.txt') as f:
    data = [list(map(int, i.split())) for i in f]


# В строке есть два числа, каждое из которых
# повторяется трижды, одно число без повторений
def f1(line):
    # Подсчитываем сколько раз повторяется каждое
    cnt = [line.count(i) for i in line]
    # 2 числа трижды: 2 * 3 = 6
    return cnt.count(3) == 6 and cnt.count(1) == 1


# Наибольшее из повторяющихся чисел
# больше неповторяющегося числа
def f2(line):
    # Все повторяющиеся
    repeat = {i for i in line if line.count(i) > 1}
    # Все неповторяющиеся
    no_repeat = [i for i in line if line.count(i) == 1]
    return max(repeat) > no_repeat[0]


# Счетчик
counter = 0

# Вычисление кол-ва строк
for line in data:
    if f1(line) and f2(line):
        counter += 1

# Вывод ответа
print(counter)

После запуска видим, что всего одна строка подходит под оба условия. Значит, в ответ пишем число 1.

Итоги

Мы разобрали первый программный тип задания 9. Его основа не меняется: файл превращается в список строк, каждое условие оформляется отдельной функцией, а подходящие строки подсчитываются.

Шаблон решения

with open('*1.txt') as file:
    data = [list(map(int, line.split())) for line in file]

def condition_1(row):
    return *2

def condition_2(row):
    return *3

count = 0
for row in data:
    if condition_1(row) and condition_2(row):
        count += 1

print(count)

Здесь

  • *1 — имя файла,
  • *2 и *3 — условия из задачи.

Если проверка одна, вторую функцию можно убрать; если условий больше, добавьте их в итоговый if через and, or или ^.

В следующей статье перейдём ко второму типу и научимся получать номера строк с помощью enumerate().

Разберём эту тему на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие