ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9026. Основная волна 2024

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, в которых сумма наибольшего и наименьшего чисел не больше суммы двух оставшихся.

with open('903.txt') as f:
    data = [list(map(int, i.split())) for i in f]


# Условие
def f(line):
    # Наибольшее
    max_of_4 = max(line)
    # Наименьшее
    min_of_4 = min(line)
    # Cумма оставшихся
    sum_rest = sum(line) - max_of_4 - min_of_4
    # Не больше суммы двух оставшихся
    return max_of_4 + min_of_4 <= sum_rest


# Счетчик
count = 0

# Вычисление кол-ва строк
for line in data:
    if f(line):
        count += 1

# Вывод ответа
print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие