ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9033. Досрочная волна 2025

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполняются оба условия:

– в строке есть два числа, каждое из которых повторяется трижды, одно число без повторений;
 – наибольшее из повторяющихся чисел больше неповторяющегося числа.

В ответе запишите только число

with open('905.txt') as f:
    data = [list(map(int, i.split())) for i in f]


def f1(arr):
    cnt = [arr.count(i) for i in arr]
    return cnt.count(3) == 6 and cnt.count(1) == 1


def f2(arr):
    pov = [i for i in arr if arr.count(i) > 1]
    nepov = [i for i in arr if arr.count(i) == 1]
    return max(pov) > nepov[0]


cnt = 0

for line in data:
    if f1(line) and f2(line):
        cnt += 1
        
print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие