ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9034. ЕГКР 2025

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите сумму чисел в строке таблицы с наименьшим номером, содержащей числа, для которых выполнены оба условия:

– в строке все числа расположены в порядке убывания;
 –  среднее арифметическое минимального и максимального чисел строки больше среднего арифметического оставшихся её чисел.

В ответе запишите только число.

with open('906.txt') as f:
    data = [list(map(int, i.split())) for i in f]


def f1(arr):
    return line == sorted(arr, reverse=True)


def f2(arr):
    arr = sorted(arr)
    mean_min_max = (arr[0] + arr[-1]) / 2
    mean_rest = sum(arr[1:-1]) / (len(arr) - 2)
    return mean_min_max > mean_rest


for line in data:
    if f1(line) and f2(line):
        res = sum(line)
        print(res)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие