ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9035. ФИПИ 2025

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите количество строк таблицы, для чисел которых выполнены оба условия:

– в строке все числа различны;
 – сумма двух наибольших чисел строки не больше суммы трёх её оставшихся чисел.

В ответе запишите только число.

with open('907.txt') as f:
    data = [list(map(int, i.split())) for i in f]


def f1(arr):
    return len(arr) == len(set(arr))


def f2(arr):
    arr.sort()
    return sum(arr[-2:]) <= sum(arr[:-2])


count = 0
for line in data:
    if f1(line) and f2(line):
        count += 1
        
print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие