ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9036. Основная волна 2025

Откройте файл электронной таблицы, содержащей в каждой строке шесть натуральных чисел. Определите наибольший номер строки таблицы, для чисел которой выполнены оба условия:

– в строке есть одно число, которое повторяется трижды, остальные три числа различны;
 – повторяющееся число строки больше, чем среднее арифметическое её неповторяющихся чисел.

В ответе запишите только число.

from statistics import mean

with open('911.txt') as f:
    data = [list(map(int, i.split())) for i in f]

for idx, line in list(enumerate(data, start=1))[::-1]:
    cnt_3 = [i for i in line if line.count(i) == 3]
    cnt_1 = [i for i in line if line.count(i) == 1]
    if len(cnt_3) == 3 and len(cnt_1) == 3 and cnt_3[0] > mean(cnt_1):
        print(idx)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие