ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9037. Основная волна 2025

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите наименьший номер строки таблицы, для чисел которой выполнены оба условия:

– в строке есть два числа, каждое из которых повторяется дважды, остальные три числа различны;
 – среднее арифметическое всех повторяющихся чисел строки меньше её максимального неповторяющегося числа.

В ответе запишите только число.

from statistics import mean

with open('912.txt') as f:
    data = [list(map(int, i.split())) for i in f]

for idx, line in list(enumerate(data, start=1)):
    cnt_2 = [i for i in line if line.count(i) == 2]
    cnt_1 = [i for i in line if line.count(i) == 1]
    if len(cnt_2) == 4 and len(cnt_1) == 3 and mean(cnt_2) < max(cnt_1):
        print(idx)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие