ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9038. Резервная волна 2025

Откройте файл электронной таблицы, содержащей в каждой строке пять натуральных чисел. Определите наибольший номер строки таблицы, для которой выполнены оба условия:

– в строке все числа различны;
 – удвоенная сумма минимального и максимального чисел строки равна утроенной сумме трёх её оставшихся чисел.

В ответе запишите только число.

with open('913.txt') as f:
    data = [list(map(int, i.split())) for i in f]


def f1(arr):
    return len(arr) == len(set(arr))


def f2(arr):
    arr.sort()
    return (arr[0] + arr[-1]) * 2 == sum(arr[1:-1]) * 3


for idx, line in list(enumerate(data, start=1))[::-1]:
    if f1(line) and f2(line):
        print(idx)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие