ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9108. Типовая задача

Откройте файл электронной таблицы, содержащей в каждой строке восемь натуральных чисел. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– в строке есть одно число, которое повторяется трижды, есть другое число, которое повторяется дважды, остальные три числа различны;
 – среднее арифметическое неповторяющихся чисел строки не больше числа, повторяющегося трижды.

В ответе запишите только число.

from statistics import mean

with open('923.txt') as f:
    data = [list(map(int, i.split())) for i in f]


def f1(arr):
    cnt = [arr.count(num) for num in set(arr)]
    return sorted(cnt) == [1, 1, 1, 2, 3]


def f2(arr):
    no_rep = [i for i in line if line.count(i) == 1]
    rep_3 = [i for i in line if line.count(i) == 3]
    return mean(no_rep) <= rep_3[0]


count = 0
for line in data:
    if f1(line) and f2(line):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие