ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9106. Типовая задача

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– среди четырёх чисел есть только одна пара равных чисел;
 – число, не являющееся ни максимальным, ни минимальным, больше 23.

В ответе запишите только число.

with open('921.txt') as f:
    data = [list(map(int, i.split())) for i in f]


def f1(arr):
    cnt = [arr.count(num) for num in set(arr)]
    return sorted(cnt) == [1, 1, 2]


def f2(arr):
    mx = max(arr)
    mn = min(arr)
    for num in arr:
        if num > 23 and num not in (mn, mx):
            return True
    return False


count = 0
for line in data:
    if f1(line) and f2(line):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие