ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9105. Типовая задача

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– наибольшее из четырёх чисел больше суммы трёх других;
 – все четыре числа различны.

В ответе запишите только число.

with open('920.txt') as f:
    data = [list(map(int, i.split())) for i in f]

def f1(arr):
    arr.sort()
    return arr[-1] > sum(arr[:-1])


def f2(arr):
    return len(arr) == len(set(arr))


count = 0
for line in data:
    if f1(line) and f2(line):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие