ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9102. Типовая задача

Откройте файл электронной таблицы, содержащей вещественные числа – результаты ежечасного измерения концентрации примесей в воде очистных установок на протяжении трёх месяцев.

Найдите разность между минимальным значением концентрации примесей на протяжении трёх месяцев и средним арифметическим значение концентрации примесей в этот период времени.
В ответе запишите только целую часть числа.

from statistics import mean

data = []
with open('910.txt') as f:
    next(f)
    for line in f:
        parts = line.replace(',', '.').split()
        numbers = list(map(float, parts[1:]))
        data.extend(numbers)

print(int(abs(min(data) - mean(data))))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие