ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9101. Типовая задача

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– квадрат наименьшего из четырёх чисел больше суммы трёх других;
 – среди четырёх чисел нет ни одного чётного.

В ответе запишите только число.

with open('909.txt') as f:
    data = [list(map(int, i.split())) for i in f]

count = 0
for line in data:
    line.sort()
    if line[0] ** 2 > sum(line[1:]) and all(num % 2 for num in line):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие