ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9100. Типовая задача

Откройте файл электронной таблицы, содержащей в каждой строке четыре натуральных числа. Определите количество строк таблицы, содержащих числа, для которых выполнены оба условия:

– наибольшее из четырёх чисел более чем вдвое меньше суммы трёх других;
 – четыре числа можно разбить на две пары чисел с равными суммами.

В ответе запишите только число.

with open('908.txt') as f:
    data = [list(map(int, i.split())) for i in f]


def f1(sorted_arr):
    return sum(sorted_arr[:3]) / sorted_arr[3] >= 2


def f2(sorted_arr):
    return sorted_arr[0] + sorted_arr[3] == sorted_arr[1] + sorted_arr[2]


count = 0
for line in data:
    line.sort()
    if f1(line) and f2(line):
        count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие