ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9103. Типовая задача

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите наибольший номер строки таблицы, для чисел которой выполнены оба условия:

– в строке есть только одно число, которое повторяется три раза, остальные четыре числа различны;
 – сумма неповторяющихся чисел строки больше суммы ей повторяющихся чисел.

В ответе запишите только число.

with open('917.txt') as f:
    data = [list(map(int, i.split())) for i in f]


for idx, line in list(enumerate(data, start=1))[::-1]:
    cnt_3 = [i for i in line if line.count(i) == 3]
    cnt_1 = [i for i in line if line.count(i) == 1]
    if (len(cnt_3) == 3 and len(cnt_1) == 4 
            and sum(cnt_1) > sum(cnt_3)):
        print(idx)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие