ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9018. Основная волна 2023

Откройте файл электронной таблицы, содержащей в каждой строке семь натуральных чисел. Определите сумму всех чисел в строке таблицы с наименьшим номером, для чисел которой выполнены оба условия:

— в строке есть два числа, каждое из которых повторяется дважды, остальные три числа различны;
 — максимальное число строки не повторяется.

В ответе запишите только число.

with open('915.txt') as f:
    data = [list(map(int, i.split())) for i in f]

for line in data:
    cnt_2 = [i for i in line if line.count(i) == 2]
    max_num = max(line)
    if len(cnt_2) == 4 and line.count(max_num) == 1:
        print(sum(line))
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие