ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 9017. Основная волна 2023

Откройте файл электронной таблицы, содержащей в каждой строке шесть натуральных чисел. Определите наименьший номер строки таблицы, для чисел которой выполнены оба условия:

— в строке есть только одно число, которое повторяется дважды, остальные четыре числа различны;
 — повторяющееся число строки не меньше, чем среднее арифметическое четырёх её неповторяющихся чисел.

В ответе запишите только число.

from statistics import mean

with open('916.txt') as f:
    data = [list(map(int, i.split())) for i in f]

for idx, line in list(enumerate(data, start=1)):
    cnt_2 = [i for i in line if line.count(i) == 2]
    cnt_1 = [i for i in line if line.count(i) == 1]
    if len(cnt_2) == 2 and len(cnt_1) == 4 and cnt_2[0] >= mean(cnt_1):
        print(idx)
        break
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие