ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6201. Авторская задача

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм:

Направо 13 Повтори 13 [Вперёд 59 Направо 120]

Определите, сколько точек с целочисленными координатами будут находиться внутри области, ограниченной линией, заданной данным алгоритмом. Точки на линии учитывать не следует.

import math as m
from turtle import *

# Базовая настройка
tracer(0)  # Отключаем анимацию

# Переменные
angles = []
coords = []
count = 0

lt(90)  # Поворот по положительному направлению оси ординат

rt(13)

# Алгоритм
for i in range(13):
    if i < 3:
        angles.append(heading())
        coords.append((xcor(), ycor()))
    fd(59)
    rt(120)

k_1 = m.tan(m.radians(angles[0]))
k_2 = m.tan(m.radians(angles[1]))
k_3 = m.tan(m.radians(angles[2]))

b_1 = coords[0][1] - k_1 * coords[0][0]
b_2 = coords[1][1] - k_2 * coords[1][0]
b_3 = coords[2][1] - k_3 * coords[2][0]


def get_min_max_coordinates(coordinates):
    min_x = m.floor(min(x for x, _ in coordinates))
    max_x = m.ceil(max(x for x, _ in coordinates))
    min_y = m.floor(min(y for _, y in coordinates))
    max_y = m.ceil(max(y for _, y in coordinates))
    return min_x, max_x, min_y, max_y


ranges = get_min_max_coordinates(coords)

for x in range(ranges[0], ranges[1]):
    for y in range(ranges[2], ranges[3]):
        if k_1 * x + b_1 >= y >= k_3 * x + b_3 and 
                k_2 * x + b_2 >= y:
            count += 1

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие