ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6038. ЕГКР 2026

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепаха выполнила следующую программу:

Повтори 6 [Вперёд 33 Направо 90 Вперёд 20 Направо 90]
Поднять хвост
Вперёд 3 Направо 90 Вперёд 9 Налево 90
Опустить хвост
Повтори 6 [Вперёд 24 Направо 90 Вперёд 25 Направо 90]

Определите, сколько точек с целочисленными координатами находится внутри пересечения фигур, ограниченных заданными алгоритмом линиями. Точки на границах этого пересечения учитывать не следует.

from turtle import *

tracer(0)
pensize(5)

scale = 20
dot_size = 4
dot_color = "#696969"
screensize(2000, 2000)

lt(90)

color("#A7D380")

for _ in range(6):
    fd(33 * scale)
    rt(90)
    fd(20 * scale)
    rt(90)

pu()
fd(3 * scale)
rt(90)
fd(9 * scale)
lt(90)
pd()

color("#F76D47")

for _ in range(6):
    fd(24 * scale)
    rt(90)
    fd(25 * scale)
    rt(90)

pu()

for x in range(10, 20):
    for y in range(4, 27):
        goto(x * scale, y * scale)
        dot(dot_size, dot_color)

print(10*23)
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие