ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 6030. ЕГКР 2025

Исполнитель Черепаха действует на плоскости с декартовой системой координат.

В начальный момент Черепаха находится в начале координат, её голова направлена вдоль положительного направления оси ординат, хвост опущен.
При опущенном хвосте Черепаха оставляет на поле след в виде линии. В каждый конкретный момент известно положение исполнителя и направление его движения.

У исполнителя существует 6 команд: Поднять хвост, означающая переход к перемещению без рисования; Опустить хвост, означающая переход в режим рисования; Вперёд n (где n — целое число), вызывающая передвижение Черепахи на n единиц в том направлении, куда указывает её голова; Назад n (где n — целое число), вызывающая перемещение в противоположном голове направлении; Направо m (где m — целое число), вызывающая изменение направления движения на m градусов по часовой стрелке; Налево m (где m — целое число), вызывающая изменение направления движения на m градусов против часовой стрелки.

Запись Повтори k [Команда 1 Команда2 … КомандаS] означает, что последовательность из S команд повторится k раз.

Черепахе был дан для исполнения следующий алгоритм.

Повтори 2 [Вперёд 28 Направо 90 Вперёд 18 Направо 90]
Поднять хвост
Вперёд 14 Направо 90 Вперёд 10 Налево 90
Опустить хвост
Повтори 2 [Вперёд 30 Направо 90 Вперёд 7 Направо 90]

Определите, сколько точек с целочисленными координатами находится внутри объединения фигур, ограниченного заданными алгоритмом линиями, включая точки на линиях.

from turtle import *

tracer(0)
pensize(3)

scale = 10
dot_size = 3
dot_color = "#696969"

lt(90)

color("#A7D380")

for i in range(2):
    fd(28 * scale)
    rt(90)
    fd(18 * scale)
    rt(90)

pu()
fd(14 * scale)
rt(90)
fd(10 * scale)
lt(90)
pd()

color("#F76D47")

for i in range(2):
    fd(30 * scale)
    rt(90)
    fd(7 * scale)
    rt(90)

pu()

# Точки только внутри пересечения
for x in range(10, 18):
    for y in range(14, 29):
        goto(x * scale, y * scale)
        dot(dot_size, dot_color)

print(29 * 19 + 31 * 8 - 8 * 15)
done()
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие