ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16018. ЕГКР

Алгоритм вычисления значения функции F(n) и G(n), где n – целое число, задан следующими соотношениями:

F(n) = F(n-4) + 3580, если n ≥ 19;
F(n) = 6 × (G(n-7) — 36), если n < 19;
G(n) = n / 20 + 28, если n ≥ 248045;
G(n) = G(n+9) — 4, если n < 248045;

Чему равно значение выражения F(673)?

from functools import lru_cache


def f(n):
    if n < 19:
        return 6 * (g(n - 7) - 36)
    else:
        return f(n - 4) + 3580


@lru_cache()
def g(n):
    if n < 248045:
        return g(n + 9) - 4
    else:
        return n / 20 + 28


for n in range(600, 248045)[::-1]:
    g(n)

print(f(673))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие