ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 16017. Типовые варианты

Алгоритм вычисления значения функции F(n), где n – натуральное число, задан следующими соотношениями:

F(1) = 2;
F(n)= 3 × F(n-1) — n, если n ≥ 2.

Чему равно значение выражения (F(2025) — F(2023) — 1) / 3²⁰²²?

from functools import lru_cache


@lru_cache()
def f(n):
    if n == 1:
        return 2
    else:
        return 3 * f(n - 1) - n


for n in range(1, 2025):
    f(n)

print((f(2025) - f(2023)) // 3 ** 2022)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие