ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14200. Авторская задача

Значение арифметического выражения 2 2025 + 2 2024 — 2 2021 — x, где х — целое положительное число, не превышающее 2030, записали в 4-ричной системе счисления.

Определите наибольшее значение х, при котором количество нулей в 4-ричной записи числа, являющегося значением данного арифметического выражения, максимально.

В ответе запишите число в десятичной системе счисления

ans = []
for x in range(1, 2031):
    num = 2 ** 2025 + 2 ** 2024 - 2 ** 2021 - x
    cnt_0 = 0
    while num:
        if num % 4 == 0:
            cnt_0 += 1
        num //= 4
    ans.append([cnt_0, x])

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие