ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14105. Типовая задача

Значение арифметического выражения 52022 – 2 · 51010 + 25850 + 2500 записали в системе счисления с основанием 5.

Определите количество цифр 4 в записи этого числа.

num = 5 ** 2022 - 2 * 5 ** 1010 + 25 ** 850 + 2500
count = 0
while num:
    if num % 5 == 4:
        count += 1
    num //= 5

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие