ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14104. Типовая задача

Значение арифметического выражения 42022 – 6 · 4522 + 5 · 64510 – 3 · 2330 — 100 записали в системе счисления с основанием 8.

Определите количество цифр 7 в записи этого числа.

num = 4 ** 2022 - 6 * 4 ** 522 + 5 * 64 ** 510 - 3 * 2 ** 330 - 100
count = 0
while num:
    if num % 8 == 7:
        count += 1
    num //= 8

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие