ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14103. Типовая задача

Значение арифметического выражения 3 · 21871801 + 7292000 – 4 · 2432100 + 812200 – 2 · 272400 – 13122 записали в системе счисления с основанием 27.

Определите в 27-ричной записи числа количество цифр с числовым значением, превышающим 8.

num = 3 * 2187 ** 1801 + 729 ** 2000 - 4 * 243 ** 2100 + 81 ** 2200 - 2 * 27 ** 2400 - 13122
count = 0
while num:
    if num % 27 > 8:
        count += 1
    num //= 27

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие