ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14102. Типовая задача

Значение арифметического выражения 3333 + 322 — 9111 — 9 записали в системе счисления с основанием 3.

Определите количество цифр 2 в записи этого числа.

num = 3 ** 333 + 3 ** 22 - 9 ** 111 - 8

count = 0

while num:
    if num % 3 == 2:
        count += 1
    num //= 3

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие