ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14101. Типовая задача

Значение арифметического выражения 1331650 – 55 ⋅ 121610  + 77 ⋅ 11510 – 3 ⋅ 11100 – 221 записали в системе счисления с основанием 11.

Определите количество цифр A в записи этого числа.

num = (1331 ** 650
       - 55 * 121 ** 610
       + 77 * 11 ** 510
       - 3 * 11 ** 100
       - 221)

count = 0

while num:
    # A = 10
    if num % 11 == 10:
        count += 1
    num //= 11

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие