ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14100. Типовая задача

Значение арифметического выражения 4 ⋅ 252022 — 2 ⋅ 52000  + 1251011 — 3 ⋅ 5100 — 660 записали в системе счисления с основанием 5.

Определите количество цифр 4 в записи этого числа.

num = (4 * 25 ** 2022
       - 2 * 5 ** 2000
       + 125 ** 1011
       - 3 * 5 ** 100
       - 660)

count = 0

while num:
    if num % 5 == 4:
        count += 1
    num //= 5

print(count)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие