ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14061. Пересдача 2026

Операнды арифметического выражения записаны в системе счисления с основанием 22.

27x9896622 + 26x3322 + 522x522

В записи чисел переменной х обозначена неизвестная цифра из алфавита 22-ричной системы счисления. Определите наибольшее значение х, при котором значение данного арифметического выражения кратно 21.

Для найденного х вычислите частное от деления значения арифметического выражения на 21 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:22]:
    num_1 = int(f'27{x}98966', 22)
    num_2 = int(f'26{x}33', 22)
    num_3 = int(f'522{x}5', 22)
    num = num_1 + num_2 + num_3
    if num % 21 == 0:
        ans.append([x, num // 21])

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие