ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14060. Резервная волна 2026

Операнды арифметического выражения записаны в системе счисления с основанием 19.

76x7964519 + 35x4219 + 332x619

В записи чисел переменной х обозначена неизвестная цифра из алфавита 19-ричной системы счисления. Определите наибольшее значение х, при котором значение данного арифметического выражения кратно 18.

Для найденного вычислите частное от деления значения арифметического выражения на 18 и укажите его в ответе в десятичной системе счисления. Основание системы счисления указывать не нужно.

from string import printable as alph

ans = []
for x in alph[:19]:
    num_1 = int(f'76{x}79645', 19)
    num_2 = int(f'35{x}42', 19)
    num_3 = int(f'332{x}6', 19)
    num = num_1 + num_2 + num_3
    if num % 18 == 0:
        ans.append([x, num // 18])

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие