ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14059. Основная волна 2026

Значение арифметического выражения 7170 + 7100 – x, где x - целое положительное число, не превышающее 2030, записали в 7-ричной системе счисления.

Определите наибольшее значение x, при котором в 7-ричной записи значения данного арифметического выражения содержится ровно 70 нулей.

В ответе запишите число в десятичной системе счисления.

ans = []
for x in range(1, 2031):
    num = 7**170 + 7**100 - x
    cnt = 0
    while num:
        if num % 7 == 0: cnt += 1
        num //= 7
    if cnt == 70:
        ans.append(x)

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие