ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14058. Основная волна 2026

Значение арифметического выражения 5150 + 5100 – x, где x - целое положительное число, не превышающее 2030, записали в 5-ричной системе счисления.

Определите наибольшее значение x, при котором количество нулей в 5-ричной записи значения арифметического выражения максимально.

В ответе запишите число в десятичной системе счисления.

ans = []
for x in range(1, 2031):
    num = 5**150 + 5**100 - x
    cnt = 0
    while num:
        if num % 5 == 0: cnt += 1
        num //= 5
    ans.append([cnt, x])

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие