ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14057. Апробация 2026

Значение арифметического выражения 9 ∙ 11210 + 8 ∙ 11150 – x, где х - целое положительное число, не превышающее 3000, записали в 11-ричной системе счисления.

Определите наибольшее значение х, при котором в 11-ричной записи числа, являющегося значением данного арифметического выражения, содержится ровно 60 нулей.

В ответе запишите число в десятичной системе счисления.

ans = []
for x in range(1, 3001):
    num = 9*11**210 + 8*11**150 - x
    cnt = 0
    while num:
        if num % 11 == 0: cnt += 1
        num //= 11
    if cnt == 60:
        ans.append(x)

print(max(ans))
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие