ЕГЭ, ОГЭ, программирование и робототехника в Калининграде

№ 14056. ФИПИ 2026

Определите количество цифр с чётным числовым значением в 36-ричной записи числа, заданного выражением:

5 ∙ 12962021 – 4 ∙ 2162022 + 3 ∙ 362023 – 2 ∙ 62024 – 2025

num = 5*1296**2021 - 4*216**2022 + 3*36**2023 - 2*6**2024 - 2025

cnt = 0
while num:
    if num % 36 % 2 == 0: cnt += 1
    num //= 36

print(cnt)
Разберём это задание на бесплатном пробном занятии

Преподаватель покажет, как решать такие задачи, и подскажет, с чего начать подготовку. Группы до 8 человек, очно в Калининграде и онлайн.

Записаться на пробное занятие